Artikel weiterleiten
Artikel editieren
Vista previa
FAQ #2544

¿Qué es PHP Extended Support de STRATO?

En este artículo te ofrecemos toda la información sobre PHP Extended Support de STRATO.

ÍNDICE DE CONTENIDOS
•    ¿Qué es PHP y qué papel juega en tu página web?
•    ¿Sigues utilizando la versión anticuada de PHP? 
•    ¿Por qué necesitas PHP Extended Support de STRATO?

•    ¿Cuándo te hemos informado de la existencia de PHP Extended Support de STRATO?
•    ¿Por qué PHP Extended Support de STRATO tiene un coste?

•    ¿Cuándo comienza PHP Extended Support de STRATO?
•    ¿No estás seguro de necesitar PHP Extended Support?
•    ¿Qué debes tener en cuenta antes de desactivar PHP Extended Support de STRATO?
•    ¿Cómo se desactiva PHP Extended Support de STRATO?

•    ¿Quieres ajustar tus scripts a una versión superior de PHP pero necesitas más tiempo?

 


¿Qué es PHP y qué papel juega en tu página web?

PHP es un lenguaje de script polivalente que sirve de base para muchas páginas web dinámicas y sistemas de gestión de contenidos, como WordPress, Joomla y Prestashop. La comunidad de PHP desarrolla constantemente PHP como lenguaje de programación: ofrece nuevas funciones y funcionalidades y cierra agujeros de seguridad.

 

�Qu� es PHP Extended Support de STRATO?-1.png

 

La Comunidad PHP ha dejado de ofrecer soporte para PHP 5.3 desde el 14/08/2014. Por ello, la comunidad de PHP ya no sigue desarrollando esta versión y ya no sigue cerrando los agujeros de seguridad.
El soporte para la versión 5.6 de PHP se dejará de ofrecer el 30/12/2018 y para la versión 7.0 de PHP el 03/12/2018.

Nosotros te ofrecemos el soporte (hasta ahora lo habíamos hecho de forma gratuita a pesar de los considerables esfuerzos de personal).
 

�Qu� es PHP Extended Support de STRATO?-1.png

 

¿Sigues utilizando la versión anticuada de PHP?

Si es así, habrás recibido un e-mail que te informa de que ahora ofrecemos soporte técnico (por ejemplo, parches de seguridad) para esta versión únicamente en el marco de PHP Extended Support de STRATO. PHP Extended Support es una prestación de pago que te ofrece STRATO. De este modo, tus páginas web seguirán estando protegidas de ataques y podrás cambiar con tranquilidad a una versión más actual de PHP.


¿Por qué necesitas PHP Extended Support de STRATO?

Hemos detectado en tu espacio web contenidos de PHP en la versión antigua. Esto se debe a que has configurado el uso de una versión antigua de PHP a través del Acceso Clientes de STRATO o mediante el uso de un archivo .htaccess.
En el artículo siguiente te explicamos cómo modificar la configuración en tu Acceso Clientes: Cómo modificar la configuración de PHP en tu paquete de Hosting.
Te recomendamos utilizar siempre una versión de PHP actual. La versión recomendada en estos momentos es PHP 7.2. De este modo podrás utilizar sin problemas las versiones actuales de las aplicaciones más populares sin problemas de compatibilidad.


¿Cuándo te hemos informado de la existencia de PHP Extended Support de STRATO?

Hace poco te informamos por e-mail de los cambios que iba a representar para ti PHP Extended Support de STRATO. Es posible que no hayas visto el correo. Te rogamos que compruebes si la dirección de e-mail que tienes con STRATO sigue siendo válida, ya que es la dirección a la que enviamos información contractual.
Aquí te explicamos cómo puedes comprobar y modificar la dirección que tienes con nosotros: ¿Cómo puedo actualizar mis datos de contrato?

 

¿Por qué PHP Extended Support de STRATO tiene un coste?

PHP Extended Support es una prestación de pago que ofrecemos a nuestros clientes de Hosting. Como la comunidad de PHP ha dejado de ofrecer soporte a las versiones más antiguas, STRATO ha asumido el mantenimiento activo de estas versiones anticuadas de PHP. PHP Extended Support de STRATO abarca, además de la versión 5.3, todas las versiones anticuadas de PHP que dejen de recibir soporte. De este modo podemos ofrecerte un servicio sin interrupciones de tu presencia web y evitar que tu página pueda ser atacada por hackers debido a una versión anticuada.
A continuación encontrarás más detalles sobre las distintas fases de soporte de PHP así como sobre todo el ciclo de vida de PHP:

A causa de versiones antiguas de PHP en los espacios web de nuestros clientes se generan potenciales agujeros de seguridad que pueden poner en peligro nuestra plataforma de hosting y, de este modo, la seguridad de los demás clientes. Según nuestras CC.GG., como cliente de STRATO estás obligado a mantener tu software actualizado. En caso de que no cumplas con esta obligación, nos veremos obligados a cerrar los agujeros de seguridad por ti. El mantenimiento de la versión antigua de PHP implica para nosotros un gran esfuerzo de administración en nuestros sistemas. Por este servicio adicional facturamos un precio mensual muy bajo para cubrir nuestros costes.
Considerando que necesitas los scripts disponibles para gestionar tu página web, hemos activado PHP Extended Support para tu contrato. De este modo, tus scripts PHP funcionarán también en el futuro. Te hemos enviado información más precisa por e-mail.
 

¿Cuándo comienza PHP Extended Support de STRATO?

PHP Extended Support de STRATO de pago para la versión 5.6 comienza a ofrecerse el 05/03/2019 y para la versión 7.0 el 05/02/2019.
Para versiones más nuevas, PHP Extended Support de STRATO comienza cuando finalice el soporte de la comunidad de PHP. A partir de este punto la comunidad de PHP dejará de mantener la versión de PHP y dejará de cerrar los agujeros de seguridad.

¿No estás seguro de necesitar PHP Extended Support?

En pocos pasos puedes probar si tu página web funciona también con una versión más nueva de PHP. Para reducir el riesgo de que la página deje de estar disponible, te recomendamos que procedas así:
•    Crea una copia de tu página en una carpeta nueva.
•    Crea un subdominio y redirígelo a la nueva carpeta.
•    A continuación, puedes cambiar a través de .htaccess en la carpeta a la nueva versión de PHP 7.2 (o a la versión 7.1).
Abre tu página web a través del subdominio y comprueba que todo funciona correctamente. Si tu página web se ejecuta sin problemas, entonces puedes cambiar la versión de PHP de tu página web en pocos clics en tu Acceso Clientes. En nuestro artículo encontrarás instrucciones paso a paso: Cómo modificar la configuración de PHP en tu paquete de Hosting

Recuerda que tras el cambio y una vez que te hayas desconectado del Acceso Clientes ya no podrás volver a la versión 5.3 de PHP. Por eso debes estar seguro de que tu página web funciona con una versión más actual antes de salir de tu Acceso Clientes.

¿Qué debes tener en cuenta antes de desactivar PHP Extended Support de STRATO?

Cuando cambies a una versión actual de PHP soportada por la comunidad, comprueba primero si tu sitio sigue funcionando. Recomendamos desactivar PHP Extended Support de STRATO únicamente después de la comprobación. El soporte de pago finalizará al final del periodo de facturación mensual.

¿Cómo se desactiva PHP Extended Support de STRATO?

Para desactivar PHP Extended Support de STRATO debes iniciar sesión en tu Acceso clientes de STRATO. A continuación, haz clic en Bases de datos y espacio web / desactivar versión de PHP.

 

 �Qu� es PHP Extended Support de STRATO?-1.png

 

Para cambiar a una versión actual de PHP, selecciona la versión que desees y guárdala haciendo clic en Guardar.

�Qu� es PHP Extended Support de STRATO?-1.png

 

Si has desactivado el servicio y ves que sigue habiendo problemas con tu sitio web, puedes cambiar a la versión antigua de PHP dentro del periodo de soporte.
A continuación se te informará de que desactivaremos el soporte al final del periodo de contratación (en nuestro ejemplo es el 06/11/2017). Accede a la vista general y haz clic en Desactivar.

�Qu� es PHP Extended Support de STRATO?-1.png
 

�Qu� es PHP Extended Support de STRATO?-5.png

 

Confirma que has realizado todos los ajustes necesarios. Sólo entonces se completará la desactivación y se interrumpirá el soporte al final del periodo de contratación.


¿Quieres ajustar tus scripts a una versión superior de PHP pero necesitas más tiempo?

En primer lugar, comprueba si es necesario realizar un ajuste de tus scripts. Muchos scripts son compatibles y funcionan con versiones PHP actuales. En caso de que no fuera así y de que debas realizar grandes ajustes en tus scripts, podrás utilizar PHP Extended Support de STRATO hasta que estés preparado para cambiar a una versión más actual.



�Qu� es PHP Extended Support de STRATO?-1.png
×
¿Te ha sido útil este artículo?    / no